Feed/CVE-2026-32773
CVE-2026-32773MEDIUMCVSS 6.1

Apache Spark History Server allows stored cross-site scripting through unescaped application names

Published Sep 2, 2026·Updated Oct 5, 2026

NVD Description

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Affected Packages (3)

org.apache.spark:spark-core_2.13MAVEN
From 3.0.0
Fixed in 3.5.8
org.apache.spark:spark-core_2.12MAVEN
From 3.0.0
Fixed in 3.5.8
pysparkPYPI
From 3.0.0
Fixed in 3.5.8

CVSS Vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References

View on NVD Search GitHub Search Google

Get alerted for CVEs like this

Register your stack and get notified within minutes when a matching CVE drops.

Start monitoring free