Feed/CVE-2026-56736
CVE-2026-56736HIGHCVSS 8.2

CVE-2026-56736

Published Sep 24, 2026·Updated Sep 24, 2026

NVD Description

phpMyFAQ is an open source FAQ web application. A stored cross-site scripting (XSS) vulnerability in versions prior to 4.2.0-alpha allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because `html_entity_decode()` converts HTML entities into executable HTML after `strip_tags()` has already passed them through, and the admin template renders the content with Twig's `|raw` filter without any output sanitization. Version 4.2.0-alpha fixes the issue.

Affected Packages (2)

thorsten/phpmyfaqCOMPOSER
Fixed in 4.2.0-alpha
phpmyfaq/phpmyfaqCOMPOSER
Fixed in 4.2.0-alpha

CVSS Vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N

References

View on NVD Search GitHub Search Google

Get alerted for CVEs like this

Register your stack and get notified within minutes when a matching CVE drops.

Start monitoring free